Project

General

Profile

Actions

Patch submission #506

closed

g_ command added

Added by Arnaud Tanguy over 13 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
libyzis
Target version:
Start date:
01/15/2009
Due date:
% Done:

100%

Estimated time:

Description

I implemented the g_ command (it move to the last non blank character of the line).
I hope this time the patch is better (I tried to follow all the advices).


Files

g_command.patch (1.54 KB) g_command.patch Arnaud Tanguy, 01/15/2009 07:34 PM
g_command2.patch (1.89 KB) g_command2.patch Arnaud Tanguy, 01/15/2009 08:38 PM
Actions #1

Updated by Thomas Capricelli over 13 years ago

Don't worry too much about the patch being 'good' or 'bad'. It's far more subtile, we just need to discuss it before integration. I still have two requests concerning this one
  • please use spaces and not tabs, especially in the lua test (it looks strange here because of that)
  • Can you add another test (inside the same block that you added, with a line that has NO space at the end, to ensure this case works well ?

thanks!

Actions #2

Updated by Arnaud Tanguy over 13 years ago

Ok, I added this test, it works perfectly as intended.
I changed my vimrc to set spaces instead of tabs, and corrected the lua script indentation..

Actions #3

Updated by Thomas Capricelli over 13 years ago

  • Status changed from New to Rejected
  • Assignee set to Arnaud Tanguy
  • Target version set to 1.0-alpha2
  • % Done changed from 0 to 100

ok, integrated as commit:a057040f7903 and commit:204816a85100

Actions #4

Updated by Thomas Capricelli over 13 years ago

  • Status changed from Rejected to Closed

oops

Actions

Also available in: Atom PDF